Generic selectors
Exact matches only
Search in title
Search in content
Search in posts
Search in pages

TFO in B11

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #68793 Reply
    VanG
    Guest

    Hi all,
    is there anybody to use TFO feature in ALU_B11 system ?
    We activated but we faced some problems…

    rrb..

    #68794 Reply
    VanG
    Guest

    … the voice quality is degradated durring the conversation..
    We use EFR and AMR, DTX…
    Please give us idea what can be the reason for this quality degradation when the TFO is used ?

    #68795 Reply
    pix
    Guest

    hi vanG,

    you should perform a MS to MS test, and see when is the VQ degraded. I guess it has to do with the codec being used.

    If you find out (or assume) that TFO+AMR is the couple that leads to bad VQ –> You can set up the TFO so that it is only activated when legacy EFR or HR is used, and not when AMR is used.

    If you search “TFO” within the topics of this forum, you should find a post with all parameters listed and all main explanations about TFO parameters.

    But the first step is to find out the codecs which are “faulty”.

    Regards,
    pix

    #68796 Reply
    VanG
    Guest

    Hi Pix,
    we performed some tests and the problem occurs in both codec(EFR and AMR_HR) but in EFR is less than AMR_HR. In TEMS logs file we saw that when the problem with voice quality occurs the SQI is with strongly fluctuating .
    The more complains are coming after TFO_AMR_HR activation but it’s normal we use more AMR_HR in this area …
    The strange is that there are complains from BSC’s with TFO active but in other BSC’s with the same parameters for TFO, there are no complains ???
    My TFO parameters are :
    EN_TFO=Enable
    EN_TFO_AMR_HR=Enable
    EN_MATCH=Enable
    EN_OPT=Enable
    FORCE TFO HR WHEN LOADED=Not forced
    FORCE TFOvsAMR=Disable
    KEEP_CODEC_HO=Disable
    DL_DTX=Enable
    DL_DTX_HR=Enable
    Is it possible that the problems are related with TC boards or some parameter in Core Network?
    Do you have idea what can be the reason for this problem ?
    Best regards,

    ..rrb

    #68797 Reply
    ian
    Guest

    Have you tried to turn off DTX in HR ?

    #68798 Reply
    VanG
    Guest

    Hi Ian,
    The DL/UL_DTX_AMR_FR/HR are recomended when the EN-TFO and EN-AMR-NB are enabled, but we faced this problems within area with DTX and in other without DTX . Also we have problem with EFR but the SQI is less degradated and there is no complains.
    The sqi decreased in the same time for both mobile.
    I think that there are some problems with TC or MSCS, or GW because the tfo parameters are the same but the problems are located in one mscs and gateway.
    What is your sw version, B10 or B11 and is the TFO activated in your system?
    Best regards,

    …rrb

    #68799 Reply
    Ian
    Guest

    Hi VanG,

    We are in B11 ed1.3 and 2 Bscs have TFO, the others without.

    Right now we are testing TFO and AMR as ed1.3 got a bug that TAC fixed with a patch, we are still testing, previously we found out bad quality when DTX is active with TFO especially with Twin TRE.

    BR
    Ian

    #68800 Reply
    VanG
    Guest

    Hi Pix and Ian,
    we continued to activate the TFO but again we faced the same problems. The problems are when the TFO_AMR_NB is active there is high SQI degradation , basic after execution of HO. From customers point of view problems are with the quality degradation and the voice interrupted.
    We tried to tuned some parameters related to TFO and disabled the DTX for AMR_NB but the problems still exist.
    My TFO parameters are :
    EN_TFO=Enable/EN_TFO_AMR_NB=Enable
    EN_MATCH=Enable/EN_OPT=DISABLE
    FORCE TFO HR WHEN LOADED=Not forced( is it correct ?)
    FORCE TFO vs AMR=Disable
    KEEP_CODEC_HO=Free choice of codec
    DL_DTX_HR=Enable/Dowlink_DTX_AMR_HR=Enable
    DTX_INDICATOR_AMR=Shall use
    Is the maching for TFO negotiation is done codecs or codecs+equal bit rate?
    What can be the reasons for this voice quality degradations?

    Best regards,

    >>rado

    #68801 Reply
    VanG
    Guest

    Hi all,
    is there anybody to use TFO feature in ALU_B11 system ?
    We activated but we faced some problems…

    #68802 Reply
    pix
    Guest

    VanG,

    The best would be to perform a MS-MS call test, and see why there is a degradation.
    Now, regarding your settings, i put a “***” where you could try to change it.

    EN_TFO=Enable/EN_TFO_AMR_NB=Enable
    EN_MATCH=Enable/EN_OPT=DISABLE *** ENABLE
    FORCE TFO HR WHEN LOADED=Not forced( is it correct ?)
    FORCE TFO vs AMR=Disable *** Enable (? This one I’m not sure what it does since the EN TFO AMR NB is enable. Perhaps it has no impact anymore.)
    KEEP_CODEC_HO=Free choice of codec *** Try a different setting “keep codec” or something like this.
    DL_DTX_HR=Enable/Dowlink_DTX_AMR_HR=Enable
    DTX_INDICATOR_AMR=Shall use

    *************************
    Now your questions:
    Is the maching for TFO negotiation is done codecs or codecs+equal bit rate?
    ** The matching is based on bitrate only. For example a AMR HR 5kbps can be matched with a AMR FR 5kbps, if needed.

    What can be the reasons for this voice quality degradations?

    ** It’s too soon to tell. Either your TFO settings (radio side and BSC side) are not yet correct, or your core network doesn’t support it properly. I would start by ensuring that the AMR set of codecs is the same everywhere in your network (BSS & NSS), then isolate the codec or the scenario which is at fault. You’re saying the issue is right after a HO ? But it’s OK after a call setup ? Then you may only have to fine tune this parameter : KEEP_CODEC_HO.

    I’m on holidays now, but i’ll try to work on that in 2 or 3 weeks.

    Cheers
    pix

    #68803 Reply
    VanG
    Guest

    Hi Pix,
    thank you for your assistance…
    I was tried to change the KEEP_CODEC_HO with different values but nothing happen and also for EN_TFO_OPT. Is the TFO_OPT enabled increase the congestions because we use AMR_HR more than FR or EFR?
    About the “FORCE TFO vs AMR=Disable” , may be this parameter there is no impact in B11.
    In the ALU document for acceptance tests there is parameter “FORCED AMR vs TFO” which should be ENABLE, but I don’t find it in the OMC-R.
    The AMR_HR bit rates for all BSCs are 7,4/5,9/5,15 and DTX(UL/DL) for AMR is active.
    I’ll check it and give you feedback.
    Best regards,

    >>rado

    #68804 Reply
    Ian
    Guest

    VanG,

    Can you try to isolate the problem which i’m sure is the switch to one codec to the next Codec, i’m awaiting for a feedback from Orange but it looks like they are only using 1 codec in AMRFR and one in AMRHR because they found out they are loosing quality when Hand Over from one cell to another especially when going HR to FR and FR to HR.

    Then you will tell me what is the sense using AMR then ? your are right but looks like its better to keep your guys on EFR or one AMRFR codec and one AMRHR Codec.

    First Try to activate only AMR FR and test one AMRFR codec after the next.

    BR
    Ian

    #68805 Reply
    VanG
    Guest

    Hi Pix and Ian,
    we perform some tests for TFO activation but still we have problems !!!
    When the TFO_AMR_NB is active there are a lot of codec changes and this affected the SQI with strong degradations.When the SQI decreased, the voice is interrupted or deaf …
    We tried to activate just one codec for AMR_HR(5,9 or 4,75) and there is no problems. The problems are when codecs fluctuated, and then the voice is affected and customers are complain from voice gaps…
    For the moment in our BSCs for AMR_HR are activate 7,4/5,9/4,75 bit rates and AMR_HR_THR123 are 9/13,5/13,5dB with 2dB hyst.
    The results from this activation was that the TFO usage increased and I think that the TFO doesn’t support the codec AMR_HR 5,15.
    The usage is OK but after bit rate changes for the RTC drops for some cells and C180d,C182 for some BSCs strongly increased ?? What can be the relation between TFO usage and RTC drop?
    About the TFO parameters, I was tried to enable or disable the TFO_MATCH but the codecs still strongly fluctuated and voice decreased.

    ..rrb

    #68806 Reply
    pix
    Guest

    vanG,

    As Ian suggested, you may want to include ALU TAC on the problem.
    Why are you saying TFO does not support HR 5.15 ?

    Your Transcoder configuration should include the HR 5.15 in the list of possible AMR codecs. I have never been in the TC myself, but that’s worth a check.

    If it’s not done this way, then TFO will be de-activated everytime the call moves to AMR HR 5.15. I believe that frequent TFO – non-TFO changes will lead to voice degradation.

    Cheers

    #68807 Reply
    VanG
    Guest

    Hi Pix,
    I think that the TFO doesn’t work with 5,15 because when we replace it with 4,75 the TFO success establishment was increased 4 times…
    The problem with this replacement is that for some cells the RTC drop increased. When we disabled the TFO for this cell the RTC drop decrease to zero?? There is no relation between them, they are on different BSC and TC boards.
    The TC counters C181d and C182 increased in the same time when the RTC drops occurs.
    The basic problem is that when the TFO_NB is active the bitrate fluctuating and the voice interrupted!!!
    Is possible that our release have a problem with TFO for AMR_NB? Do you know is thre somebody to activate this for B11.

Viewing 15 posts - 1 through 15 (of 16 total)
Reply To: Reply #68806 in TFO in B11
Your information:




<a href="" title="" rel="" target=""> <blockquote cite=""> <code> <pre class=""> <em> <strong> <del datetime="" cite=""> <ins datetime="" cite=""> <ul> <ol start=""> <li> <img src="" border="" alt="" height="" width="">