Generic selectors
Exact matches only
Search in title
Search in content
Search in posts
Search in pages

slow GSM in roaming

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #56054 Reply
    yuli
    Guest

    Hello,
    Here is my problem.
    When switching on and giving the pin code it takes sometimes a long times to be registered on the network in roaming.

    It’s an M2M application with battery. So the GSM is often power OFF.
    It’s only at the 1st try that it takes sometimes a long time.

    A developper of this GSM made some test here, and trace the GSM answer.

    We received the 0x11 error status = network failure.

    1) when pin code is OK, the GSM search for available frequencies.
    2) then according the priority list in the SIM card + those in GSM : it tries to register :
    we receive the 0x11 error 4 times.
    then it tries another operator….

    And after x minutes : YEs it’s connected.

    What is this error ? why are we rejected ?

    We have the same feeling in France + Switzerland + sometimes in Belgium.

    For these test we don’t force an operator, we are in automatic mode.
    The CSQ is good.
    It’s a bi-band GSM 900-1800.

    I have seen the same feeling on a wavecom GSM (but these time I don’t have any trace to confirm it was the same error).

    I really have no support with French operator and swiss.

    Any idea ?
    thanks
    yuli

    #56055 Reply
    yuli
    Guest

    In GSM document :

    This cause is sent to the MS if the MSC cannot service an MS generated request because of PLMN failures, e.g.
    problems in MAP.

    Someone could explain me how it work ?
    MSC job ?

    Is there no Qos ?
    Thanks

    #56056 Reply
    Pix
    Guest

    sorry, i can’t help.

    you mean after x minutes, the Ms can attach the first network it has tried? How many networks are tried ?

    On the succesful network, how many times did it send the location update request?

    #56057 Reply
    Pan
    Guest

    Dear, yuli!
    Perhaps it is a Location Update Reject. You must trace MAP signalling on interface between visited network VLR and your HLR. If there is no message between VLR and HLR when MS is switch on for the first time, then probably SCCP-routeing failure does exist in local MSC.
    Probably there are SCCP problems in transit networks.

    #56058 Reply
    yuli
    Guest

    Pix,
    It tries on 3 networks.

    “how many times did it send the location update request?”
    That’s random. Sometimes only 1 request, sometimes after 10 requests or more.

    As I understand it tries 4 times the same operator, and if it’s failed it tries another.
    ____________
    Pan,
    Yes it’s a location update reject. but I think only the operator could log the exchange between VLR + HLR, right ?
    I already ask to the swiss operator to to this job, but quite complicated, it seems they only have 3 days of log with roaming operation, and they are not fast to react.

    Thanks all

    #56059 Reply
    Pan
    Guest

    Dear, yuli!
    Your problem is located on VLR-HLR-interface and you better to get trace from it. As you said, sometimes only 1 request is required for succesfull registration, sometimes 10 or more in single roaming network. Hence, most likely than not there is routeing problem on signalling path between VLR and HLR, especially if SIGTRAN (IP-network) is used for transportation of MAP-signalling between VLR and HLR. Also congestion is possible in your home network or in transit network.

Viewing 6 posts - 1 through 6 (of 6 total)
Reply To: Reply #56056 in slow GSM in roaming
Your information:




<a href="" title="" rel="" target=""> <blockquote cite=""> <code> <pre class=""> <em> <strong> <del datetime="" cite=""> <ins datetime="" cite=""> <ul> <ol start=""> <li> <img src="" border="" alt="" height="" width="">