Generic selectors
Exact matches only
Search in title
Search in content
Search in posts
Search in pages

Calling Number IE problem (CLID)

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #29197 Reply
    Mac
    Guest

    Hello,

    I have a Cisco AS5300 with 12.2(15)T14 IOS version onboard and two e1 interfaces connected to PSTN.

    I would like to send CLID in an outgoing ISDN calls.
    I am using SIP to call Cisco. Unfortunately i always get the following debug message and no CLID on pstn side:
    EVENTd: pak_private_number: Calling Number IE is being stripped
    EVENTd: pak_private_number: Packing Calling Pty. Num. without digits
    SERROR: pak_private_number: didn’t copy oct3a reason: not CALLER_NUMBER_IE
    EVENTd: pak_public_number: Calling Number IE is being stripped.

    What is more the outgoing call sends the base number of my number range.

    Could You please give me an advice how to get out of that.

    Thanks,
    Mac

    #29198 Reply
    Mac
    Guest

    Here you can find additional debug information:

    Mar 17 14:22:27: Copying Network Provided #: 224444400 to calling number
    Mar 17 14:22:27: //-1/xxxxxxxxxxxx/CCAPI/ccSetOctet3aPI: (pi=0x0)
    Mar 17 14:22:27: //-1/xxxxxxxxxxxx/CCAPI/ccSetOctet3aSI: (si=0x3)
    Mar 17 14:22:27: //-1/xxxxxxxxxxxx/CCAPI/ccSetOctet3NPI: (NPI=1)
    Mar 17 14:22:27: //-1/xxxxxxxxxxxx/CCAPI/ccSetOctet3TON: (ToN=144)
    Mar 17 14:22:27: //-1/xxxxxxxxxxxx/CCAPI/ccCheckClipClir:
    Mar 17 14:22:27: Leaving ccCheckClipClir
    calling number is: “224444400”
    calling oct3 is: 0x1
    calling oct3a is: 0x83
    Mar 17 14:22:27: //2548/70F76CB184EB/CCAPI/ccCallSetupRequest: after ccCheckClipClir – calling oct3a is:0x83
    Mar 17 14:22:27: //2548/70F76CB184EB/CCAPI/ccCallSetupRequest: dest pattern T, called 223333300, digit_strip 1
    Mar 17 14:22:27: //2548/70F76CB184EB/CCAPI/ccCallSetupRequest:
    Mar 17 14:22:27: callingNumber=224444400, calledNumber=223333300, redirectNumber= display_info=224444400 calling_oct3a=83
    Mar 17 14:22:27: accountNumber=224444400, finalDestFlag=1,

    Mar 17 15:06:40: —– ccCallInfo IE subfields —–
    Mar 17 15:06:40: cisco-ani=224444400
    Mar 17 15:06:40: cisco-anitype=0
    Mar 17 15:06:40: cisco-aniplan=1
    Mar 17 15:06:40: cisco-anipi=0
    Mar 17 15:06:40: cisco-anisi=3
    Mar 17 15:06:40: dest=223333300
    Mar 17 15:06:40: cisco-desttype=0
    Mar 17 15:06:40: cisco-destplan=0
    Mar 17 15:06:40: cisco-rdn=
    Mar 17 15:06:40: cisco-rdntype=0
    Mar 17 15:06:40: cisco-rdnplan=0
    Mar 17 15:06:40: cisco-rdnpi=0
    Mar 17 15:06:40: cisco-rdnsi=0
    Mar 17 15:06:40: cisco-redirectreason=-1

    I have following config dial-peer:
    dial-peer voice 99 pots
    destination-pattern T
    clid network-number 224444400
    direct-inward-dial
    port 0:D
    forward-digits all

    Any suggestions?

    #29199 Reply
    Mac
    Guest

    I’ve changed the IOS ver and the problem is solved in 12.3(13).

    Anyway i do not know if i could overcome this case in 12.2(15). I quess, rather not.

    Thanks.

Viewing 3 posts - 1 through 3 (of 3 total)
Reply To: Calling Number IE problem (CLID)
Your information:




<a href="" title="" rel="" target=""> <blockquote cite=""> <code> <pre class=""> <em> <strong> <del datetime="" cite=""> <ins datetime="" cite=""> <ul> <ol start=""> <li> <img src="" border="" alt="" height="" width="">