Generic selectors
Exact matches only
Search in title
Search in content

Sending all but some prefixes with D3000

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #29078 Reply
    Nimri
    Guest

    Hello.

    I’d like to configure next call routing scheme using Quintum D3000:

    All calls from PBX switched to PSTN except those which have special prefixes (international and long distance). These prefixed calls have to be routed to IP after deleting this prefixes first.

    It seems to be easy but I still can not figure how to do this.

    If I’m setting these prefixes in the config sys# then D3000 tries to match dialed numbers with configured sroutes AFTER stripping numbers of prefixes. And to be able to route all international calls through IP I have to set some sroute like this:

    Static Route #1
    RouteName = myroute
    Gkmode = Destination is a Gateway (0)
    CallSignalAddress = xxx.xxx.xxx.xxx:1720
    1:* Public LAM priority(10)

    And that means that ALL calls will try go through IP, not only those with prefixes.

    And if I do not set prefixes in the config sys# then I have to delete them somehow else. I can not find anything helpful except “outdel” command in the config iptg#. It is sadly enough that it deletes number of digits unconditionally and prefixes I’m interested in have different length. But ok. Let’s make such scheme at least for one prefix (international 810).

    If documerntation has to be trusted then such configuration must have something like this:

    config iptg# print
    Incoming IP call delete digits = 0
    Incoming IP call prefix =
    Outgoing IP call delete digits = 3
    Outgoing IP call prefix =
    Prefix Trunk ID = no(0)
    Default Trunk = No
    External Routing Request = no(0)
    Display Information ID = Tenor-Gateway

    Static Route #1
    RouteName = myroute
    Gkmode = Destination is a Gateway (0)
    CallSignalAddress = xxx.xxx.xxx.xxx:1720
    1:810* Public LAM priority(10)
    2:* Private LAM priority(10)

    This is due to some “feature” which say that after applying “outdel” to dialed number Quintum changes this number from public to private and tries to find match for dialed number before and after such prefix stripping.
    But it still does not work as believed.
    Such configuration really routes necessary calls after stripping this “810” prefix. But for unknown reason it also tries to send SOME (not all) other calls to IP using this sroute. It looks like some bug we are not able to fix yet.

    We are using software version P4-2-20-28 and first generation D3000.

    I hope that somebody may know how to configure such scheme because Quintum just does not have all necessary documentation at their web site and we are almost ready to nominate their technical support as “the slowest ever”. 🙁

    Thank you.

    #29079 Reply
    MikeM
    Guest

    Nimri,

    Unfotunately you have hit a limitation in the D3000. You cannot configure it to route on a prefix and strip it off after the route decision. Quintum’s newer generation units (DX/AS/AX) does have this ability.

    #29080 Reply
    Nimri
    Guest

    Thank you.

    I was able to build this scheme using GNU Gatekeeper (thanks to http://www.gnugk.org/).

    It looks stupid (scheme, not gatekeeper!) because I had to prepend all calls with country code using D3000’s config sys# settings (actually, any prefix will help), parse all calls at GNU GK, delete some prefixes (like country code+interested prefix) and then allow only calls without such country code prefix.
    But it works. Maybe it will help somebody who needs similar scheme.

    Ahh. I become more and more impressed with D3000’s weird logic.
    Who said Quintum that their equipment should prepend all calls with countrycode+areacode and just delete long distance and international prefixes? Due to this called numbers starting to look like:

    1. intlprefix+E164 ->(transformed into)-> countrycode+areacode+E164 but D3000 should just strip it of intlprefix and transform to that E164 part
    2. ldprefix+national destination code+subscriber number -> countrycode+areacode+national destination code+subscriber number when it should be like countrycode+national destination code+subscriber number (E164) after transformation

    The only calls it works right with are local ones:

    3. subscriber number -> countrycode+areacode+subscriber number

    But should I complain? No, I think. Because it seems that anybody who was able to make something operational with such buggy equipment will be able to use any other equipment without any problems. It’s just like learning kung-fu with lead pieces attached to legs and jumping over trees later after removing such load. 🙂

Viewing 3 posts - 1 through 3 (of 3 total)
Reply To: Sending all but some prefixes with D3000
Your information:




<a href="" title="" rel="" target=""> <blockquote cite=""> <code> <pre class=""> <em> <strong> <del datetime="" cite=""> <ins datetime="" cite=""> <ul> <ol start=""> <li> <img src="" border="" alt="" height="" width="">